CentOS+WordPressで質問です。

Writer: admin Type: foresth Date: 2019-01-05 00:00
CentOS+WordPressで質問です。環境はCentOS 7.5Apache 2.4PHP 5.4wordpress 4.9.8MariaDB 10.1SElinux=[無効]mod_security[なし]使えてはいるのですが、あるテンプレートの機能の一部だけで500エラーがでます。(他の機能は正常に保存や画面遷移ができます)テンプレート自体は、レンタルサーバーで動作できてるのでこちらでの何か権限に関わるところの設定が悪いのだと思います。プラグインもデフォルトにしても症状は同じです。基本的はパーミッション設定は、もう問題ないはずなのですが・・・CentOS 7.5+・・・で、「これはしておかないといけないよ。」みたいなのありますか?WAFにすると問題が起きるらしいのですが、ローカルのサーバには入ってないのですが。あとなにか、500が出そうな基本的な問題?設定があるのでしょうか?共感した0###パッと思いつくのは必要なPHPのモジュールが入ってないとかかね500ってのは権限もそうだけどスクリプトエラーも500になるから、エラーログ漁れば何かしら手掛かりあるんでないかと思うナイス0
###ありがとうございます。昨晩も何が違うのだ?とそうえいばCGIは許可してなかったのでこれか?と思い飛び起きてhttpd.conf書き換えたのですがダメで途方にくれてました。なにぜ、ネットに出ている設定方法の猿真似が80%を占めるので。早速、ご教示の方向で、調べてみます。そうですね、CGIでよくサーバーエラー500出してましたから(ただ気になるのがfirefoxのときだけエラーにならず白紙なので、やはりPHP絡みかもしれませんね。)回答をもらってこんなに感謝したことはないです。本当にありがとうございました。
###ありがとうございました。おかげさまで解決しました。内容は、エラーログを見てもわかる人ではないのでPHPのモジュール絡みだということでこの際と思い(WP用的な記事で)PHP7を入れたら正常に動作しました!

 

TAG